
How To Use SPM
(A)準備 (pp.2-4)

脳を標準化する場合の流れ

(B) Realign (motion correction) (pp.5-7)

(C) Slice timing correction (pp.8-9)

(D)Coregister (pp.10)

(E) Normalise (pp.11-14)

(F) T1画像を用いたCoregister(pp.16-17)

(G) T1画像を用いたNormalise(pp.18-21)

(H) Smooth (pp.22)

(I) Model specification & parameter estimation 
[Block design] (pp.16-35)

脳を標準化しない場合の流れ

(J) Event Related design解析の準備(準備中)

(K) Model specivication & parameter estimation 
[Event Related design] (pp.37-47)

(L) Normaliseがうまく行かない場合(pp.49-53)

(M)バッチ処理（スクリプト）(pp.54-58)
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A.準備・使用データ
• fMRI mini schoolで撮像したデータ
• /usr4/minifmri/
• 作業ディレクトリ：
• /usr4/asamizu/spm_tutorial/minischool/

090213/epirri/
• EPI data
• Block Design: run1X_analyze/run1X-****.img

(.hdr) 
• FOV: 24cm x 24cm
• Matrix dimensions: 64 x 64 x 23 x 152 vols
• resolution: 3.75mm x 3.75mm x 5mm
• Event Related Design: run2X_analyze /

run2X-****.img(.hdr)
• FOV:  20cm x 20cm x 5 cm
• Matrix dimensions: 128 x 128 x 10 x 215 

vols
• resolution: 1.5625mm x 1.5625mm x 5mm

• Anatomy data
• Block Design: anat_plan1X/anat_plan1X.img
• FOV: 24cm x 24cm
• Matrix dimensions: 128 x 128 x 23 x 152 

vols
• resolution: 1.875mm x 1.875mm x 5mm
• Event Related Design: anat_plan2X/

anat_plan2X.img
• FOV:  20cm x 20cm x 5 cm
• Matrix dimensions: 128 x 128 x 10 x 215 

vols
• resolution: 1.5625mm x 1.5625mm x 5mm

• 軸合わせ
• 【注】slice方向の軸は固定（SPMでのslice 

timing correctionができない）
• *.sdt/.spr形式の段階でraxisを利用して軸
を/Application/spm8/templates/ディレクト
リにある画像ファイルのものに合わせ
る。
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A.準備・SPM起動

1. Matlab起動

2. Command Windowで ‘spm’と入力

3. 現れたウィンドウ上の‘fMRI’ボタンをク
リック

4. ‘SPM8: Menu‘ウィンドウより、[Utils] -> 
[CD]をクリックしてCurrent Directory
（作業ディレクトリ）を選択
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A.準備・画像の向きの確認

1. ‘Check Reg‘ボタンをクリック

2. ファイル選択ダイアログが出現

3. ‘/Applications/smp8/templates/‘ディレクト
リにある’T1.nii’を選択

4. さらに自前の解剖画像‘anat_plan1.img’を
選択

5. ‘Done‘をクリック

6. Graphic Windowに二つの画像が並べられ
て表示される。この時点で画像の向きが
異なるようであれば、raxis等を用いて画
像の軸変換を施して’T1.nii’に合わせる.

7. EPI画像についても同様の確認を行う
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1. プルダウンメニュー‘Realign...’より’Realign 
(Est & Res)’を選択 

2. Batch Editorが出現

3. ‘Data’を選択

4. ‘New: Session’をクリック

5. ‘Data’の下に‘Session’欄が出現

6. ‘Select Files’をクリック

7. ‘Session‘対象のファイルを選択するダイア
ログが出現

8. 解析の対象となるSessionのEPIファイル 
‘exp1-****.img‘ をすべて選択

9. ‘Done’をクリック

B.Realign
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10. ‘Estimation Options’下の‘Quality’を選択 

11. ‘Edit Value’をクリック

12. ‘Quality’のデフォルト値0.9を1に変
更、’OK’をクリック

13. ‘Reslice Options’下の‘Resliced images’をク
リック

14. ‘All Images + Mean Image’を選択

15. ‘Reslice Options’下の‘Filename Prefix’は’r‘の
まま

16. これで準備ができたので、緑色に点灯し
ている実行ボタン「▶」をクリックして
バッチ処理を実行する

B.Realign
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17. Interactiveウィンドウにプログレスバーが
表示される。

18. プログレスバーが1回目に100%に到達す
るとGraphicsウィンドウに結果が表示さ
れる

19. プログレスバーが2回目に100%に到達す
るとrealign (Est & Res)の処理は完了

20. 処理済みの画像は元ファイル名の先頭
に’r‘をつけた ‘rexp1-****.img‘として保存さ
れる

21. 平均画像は ‘meanexp1-0000.img‘として保
存される

22. 動きに関する6つのパラメータの記録
が‘rp_exp1-0000.txt’に保存される。

B.Realign
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1. ‘Slice timing’をクリック 

2. Batch Editorが出現

3. ‘Data’を選択

4. ‘New: Session’をクリック

5. ‘Data’の下に‘Session’欄が出現

6. ‘Select Files’をクリック

7. ‘Session‘対象のファイルを選択するダイア
ログが出現

8. 解析の対象となるSessionのEPIファイ
ル‘rexp1-****.img’をすべて選択

9. ‘Done’をクリック

C.Slice timing correction
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10. Batch Editor上で‘Number of Slices’を選択 

11. ‘Edit Value’をクリック

12. ‘Number of Slices’に’23’を入力。’OK’をク
リック

13. 同様にその他のパラメタの値を入力

1. TR: 2.66

2. TA: 2.54 (=TR-(TR/[#of slices]))

3. Slice order : 1 13 2 14 3 15 4 16 5 17 6 18 
7 19 8 20 9 21 10 22 11 23 12

4. Reference Slice : 18 (順番上中央のスライ
ス)

5. Filename Prefix : a

14. これで準備ができたので、緑色に点灯し
ている実行ボタン「▶」をクリックして
バッチ処理を実行する

15. 処理済みの画像は元ファイル名の先頭
に’a‘をつけた ‘arexp1-****.nii‘として保存さ
れる

16.

C.Slice timing correction
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1. ‘Coregist(Estimate)’をクリック 

2. Batch Editorが出現

3. ‘Reference Image’を選択

4. ‘Select Files’をクリック

5. ファイルを選択ダイアログが出現

6. 解剖画像‘anat_plan1X.img’を選択

7. ‘Done’をクリック

8. ‘Source Image’で‘meanexp1-0000.img’を選
択

9. ‘Other Images’で‘arexp1-****.img’を選択

10. これで準備ができたので、緑色に点灯し
ている実行ボタン「▶」をクリックして
バッチ処理を実行する

D.Coregister
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1. プルダウンメニュー‘Normalis...’より
Normalize (Estimate)を選択 

2. Batch Editorが出現

3. ‘Data’を選択

4. ‘New: Subject’をクリック

5. ‘Data’の下に‘Subject’欄が出現

6. ‘Source Image’を選択

7. ‘Select Files’をクリック

8. ‘Source Image’選択のダイアログが出現

9. 1st volumeのimgファイル（ここで
は‘arexp1-0000.img’）を選択

10. ‘Done’をクリック

E.Normalise

4

1

7
2 3

5 6

8

10

7

9

2014年4月4日金曜日



11. Batch Editor上の‘Template Image’を選択

12. ‘Select Files’をクリック

13. ‘Template Image’ダイアログにて’/
Application/spm8/templates/‘上の‘EPI.nii’を
選択

14. ‘Done‘ボタンをクリック

15. Batch Editorにある矢印ボタンが緑色にな
り、実行可能な状態なる。矢印ボタンを
クリックしてNormaliseを実行

16. Normalise(Estimate)が完了する
と、‘***_sn.mat‘ファイルができる。

E.Normalise
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17. プルダウンメニュー‘Normalis...’から
Normalize (Write)を選択

18. Batch Editorが開く

19. Dataを選択

20. ‘New: Subject’をクリック

21. Dataの下に ‘Subject’欄が出現

22. ‘Parameter File’をクリック

23. ‘Select File‘をクリック

24. ‘Source Image’選択のダイアログが出現

25. 14でできた‘arexp1-0000_sn.mat‘ファイ
ル’を選択

26. ‘Done’をクリックして選択完了
E.Normalise
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27. ‘Images to Write’をクリック

28. ‘Select File‘をクリック

29. normaliseするEPIデータを全て選択し
て‘Done’をクリック

30. ‘Image to Write’欄にEPI画像が登録さる。

31. Batch Editorにある矢印ボタンが緑色にな
り、実行可能な状態なる。矢印ボタンを
クリックしてNormaliseを実行

32. 元のEPI画像のファイル名‘arexp1-
****.img’の先頭に’w’の付いたファイル
名‘warexp1-****.img’でNormaliseされた画
像が保存される

E.Normalise
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T1画像を用いたCoregistration

2014年4月4日金曜日



1. ‘Coregist(Estimate)’をクリック 

2. Batch Editorが出現

3. ‘Reference Image’を選択

4. ‘Select Files’をクリック

5. ファイルを選択ダイアログが出現

6. 高解像度解剖画像‘3D_mazX_DT.img’を選
択

7. ‘Done’をクリック

8. ‘Source Image’で‘anat_plan1_testX.img’を選
択

9. ‘Other Images’で‘arexp1-****.img’を選択

10. これで準備ができたので、緑色に点灯し
ている実行ボタン「▶」をクリックして
バッチ処理を実行する

F.Coregister by use of T1 images
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11. Graphicsウィンドウに 

12. 変換行列が生成される

F.Coregister by use of T1 images
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1. プルダウンメニュー‘Normalis...’より
Normalize (Estimate)を選択 

2. Batch Editorが出現

3. ‘Data’を選択

4. ‘New: Subject’をクリック

5. ‘Data’の下に‘Subject’欄が出現

6. ‘Source Image’を選択

7. ‘Select Files’をクリック

8. ‘Source Image’選択のダイアログが出現

9. 高解像度解剖画像‘3D_mazX_DT.img’を選
択

10. ‘Done’をクリック

G.Normalise by use of T1 images
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11. Batch Editor上の‘Template Image’を選択

12. ‘Select Files’をクリック

13. ‘Template Image’ダイアログにて’/
Application/spm8/templates/‘上の‘T1.nii’を
選択

14. ‘Done‘ボタンをクリック

15. Batch Editorにある矢印ボタンが緑色にな
り、実行可能な状態なる。矢印ボタンを
クリックしてNormaliseを実行

16. Normalise(Estimate)が完了する
と、‘***_sn.mat‘ファイルができる。

G.Normalise by use of T1 images
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17. プルダウンメニュー‘Normalis...’から
Normalize (Write)を選択

18. Batch Editorが開く

19. Dataを選択

20. ‘New: Subject’をクリック

21. Dataの下に ‘Subject’欄が出現

22. ‘Parameter File’をクリック

23. ‘Select File‘をクリック

24. ‘Source Image’選択のダイアログが出現

25. 14でできた‘3D_mazX_DT_sn.mat‘ファイ
ル’を選択

26. ‘Done’をクリックして選択完了
G.Normalise by use of T1 images
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27. ‘Images to Write’をクリック

28. ‘Select File‘をクリック

29. normaliseするEPIデータを全て選択し
て‘Done’をクリック

30. ‘Image to Write’欄にEPI画像が登録さる。

31. Batch Editorにある矢印ボタンが緑色にな
り、実行可能な状態なる。矢印ボタンを
クリックしてNormaliseを実行

32. 元のEPI画像のファイル名‘arexp1-
****.img’の先頭に’w’の付いたファイル
名‘warexp1-****.img’でNormaliseされた画
像が保存される

G.Normalise by use of T1 images
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1. Menuより‘Smooth‘ボタンをクリック

2. Batch Editorが開く

3. ‘Image to Smooth’をクリック

4. ‘Select Files’をクリック

5. ダイアログが開き、そこで先程Normalise
したEPI画像 ‘warexpI-****.img’ 全てを選択
して‘Done’を

6. smoothing[FWHM]は8mm（デフォルト）
のまま

7. 緑色になった矢印ボタンを押して実行

8. smoothされたEPI画像が ファイル名の先
頭に’s‘のついた‘swarexpI-****.img‘として保
存される

H.Smooth
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Block Design
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• 作業ディレクトリ指定

1. ‘Specify 1st-level‘ボタンをクリック

2. Batch Editor起動

3. ‘Directory’欄をクリック

4. ‘Select Files’をクリック

5. 解析結果’***.mat’の保存先となるディレク
トリを選択

6. ‘Done’をクリック

I.Model specification & parameter estimation [Block Design]
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• Timing parameterの設定

1. ‘Timing parameter’下の‘Units for design‘を
クリック

2. [Scans],[Seconds]が選択可能になる。ここ
では[Scans]を選択

3. ‘Interscan interval’をクリック

4. ‘Edit Value’をクリック

5. Volume TRを秒単位（ ここでは2.66秒）で
入力、 ‘OK’をクリック

6. 同様に‘Microtime resolution‘にslice数であ
る’23’、‘Microtime onset’に’1’を入力

7. 同様に‘Timing parameter’下の‘Microtime 
onset‘に’1

I.Model specification & parameter estimation [Block Design]
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• Data & Designの設定

1. ‘Data & Design’をクリック

2. ‘New: Subject/Seesion’をセッション分ク
リック。ここでは1回

3. ‘Scans’をクリック

4. ‘Select Files’をクリック

5. ダイアログが現れるので、そこでEPIデー
タ‘swarexp1-****.img‘をすべて（152枚）選
択して‘Done’をクリック

I.Model specification & parameter estimation [Block Design]
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• Data & Designの設定

6. ‘Conditions’をクリック

7. ‘New: Conditions’を条件の数だけクリッ
ク。ここでは2回

8. ‘Conditions’->‘Condition’一つ目->‘Name’を
クリック

9. ‘Edit Value‘をクリック

10. ‘Name‘ウィンドウが現れるので条件の名
前を記す。ここでは’LL/RU’

I.Model specification & parameter estimation [Block Design]
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• Data & Designの設定

11. ‘Onsets’をクリック、‘Edit Value’をクリッ
ク

12. ‘Onsets’入力ウィンドウが開き、条件’LL/
RU’刺激のonset volumeを入力する。ここ
では’9 41 57 89 105 137’と入力。’OK’をク
リック

13. ‘Conditions’下の‘Durations’をクリッ
ク、‘Edit Value‘をクリック

14. ‘Durations‘に刺激提示のvolume数’8‘を入力

15. 同様に条件’LU/RL‘についても入力する

1. Name: LU/RL

2. Onsets: 25 41 57 73 121 137

3. Durations: 8

I.Model specification & parameter estimation [Block Design]
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• Data & Designの設定

16. ‘Basis Functions’をクリック

17. ‘Canonical HRF’を選択

18. Batch Editorにある▶ボタンが緑色にな
り、スクリプトが実行可能になる。

19. [File] -> [Save Batch]で処理の内容を、例
えば‘Design.mat‘という名前を付けて保存
すれば、同じ条件の実験データについて
も[Specify 1st-level]->[File]->[Load Batch]で
利用できる

20. 緑色の▶ボタンをクリック、Design 
Matrix が計算され、‘SPM.mat‘として自動
保存される

21. Design Matirxが表示される

I.Model specification & parameter estimation [Block Design]
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• Estimation

1. ‘Estimate’をクリック

2. Batch Editorが表示される

3. ‘Select SPM.mat’をクリック

4. ‘Select Files’をクリック

5. ダイアログが現れるので、‘Data & 
Design’で作成された‘SPM.mat’を選択

6. ‘Done’をクリック

7. 矢印ボタンをクリックして実行

I.Model specification & parameter estimation [Block Design]
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• Results

1. ‘Results’をクリック

2. ファイル選択のダイアログが現れる

3. ‘Data & Design’で作成された‘SPM.mat’を選
択

4. ‘Done’をクリック

5. ‘SPM contrast manager’が現れる

I.Model specification & parameter estimation [Block Design]
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• Results

6. ‘t-contrast’をクリック

7. ‘Define new contrast...‘ボタンをクリック

8. name欄に‘LL/RU’と入力

9. contrast欄に‘1 0’と入力

10. ‘OK‘ボタンをクリック

11. contrasts欄に出来上がったコントラスト
が表示される

12. 同様に‘LU/RL‘コントラストについてもつ
くる（name:’LU/RL’, contrast:’0 1’）

I.Model specification & parameter estimation [Block Design]
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• Results

13. ‘001{T}:LL/RU’を選択

14. ‘Done‘ボタンをクリック

15. ‘apply masking‘では‘none’をクリック

16. ‘title for comparison’に‘LL/RU’と入力

17. ‘p value adjustment to control’では‘none’を
クリック

18. ‘threshold {T or p value}’にp値‘0.001’（デ
フォルト）を入力

19. ‘extent threshold {voxels}’に’0’（デフォル
ト）と入力

I.Model specification & parameter estimation [Block Design]
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• Results

20. Graphic windowにactivation mapが表示さ
れる

21. ‘whole brain‘ボタンをクリックする

22. Graphic windowに全体のactivated clusters
が表示される

I.Model specification & parameter estimation [Block Design]
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• Results

23. プルダウンメニュー‘overlays...’より

24. ‘sections’を選択

25. ダイアログにて‘/Applications/spm8/
canonical/‘ディレクトリ
の‘single_subj_T1.nii’を選択、‘Done‘ボタン
をクリック

26. T1強調画像の上にactivationが重ねて表示
される

I.Model specification & parameter estimation [Block Design]
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Event - Related Design
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• 作業ディレクトリ指定

1. ‘Specify 1st-level‘ボタンをクリック

2. Batch Editor起動

3. ‘Directory’欄をクリック

4. ‘Select Files’をクリック

5. 解析結果’***.mat’の保存先となるディレク
トリを選択

6. ‘Done’をクリック

K.Model specification & parameter estimation [Event Rlated Design]
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• Timing parameterの設定

1. ‘Timing parameter’下の‘Units for design‘を
クリック

2. [Scans],[Seconds]が選択可能になる。ここ
では[Seconds]を選択

3. ‘Interscan interval’をクリック

4. ‘Edit Value’をクリック

5. Volume TRを秒単位（ ここでは2.94秒）で
入力、 ‘OK’をクリック

6. 同様に‘Microtime resolution‘にslice数であ
る’23’、‘Microtime onset’に’1’を入力

K.Model specification & parameter estimation [Event Rlated Design]
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• Data & Designの設定

1. ‘Data & Design’をクリック

2. ‘New: Subject/Seesion’をセッション分ク
リック。ここでは1回

3. ‘Scans’をクリック

4. ‘Select Files’をクリック

5. ダイアログが現れるので、そこでEPIデー
タ‘sarexp2-****.img‘をすべて（215枚）選
択して‘Done’をクリック

K.Model specification & parameter estimation [Event Rlated Design]
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• Data & Designの設定

6. ‘Conditions’をクリック

7. ‘New: Conditions’を条件の数だけクリッ
ク。ここでは2回

8. ‘Conditions’->‘Condition’一つ目->‘Name’を
クリック

9. ‘Edit Value‘をクリック

10. ‘Name‘ウィンドウが現れるので条件の名
前を記す。ここでは’HM’

K.Model specification & parameter estimation [Event Rlated Design]
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• Data & Designの設定

11. ‘Onsets’をクリック、‘Edit Value’をクリッ
ク

12. ‘Onsets’入力ウィンドウが開き、条
件’HM’刺激のonset volumeを入力する。こ
こでは？で作られたテキストファイルの
中身をコピー＆ペーストして入
力。’OK’をクリック

13. ‘Conditions’下の‘Durations’をクリッ
ク、‘Edit Value‘をクリック

14. ‘Durations‘に刺激提示時間‘2.98‘を入力

15. 同様に条件’VM‘についても入力する

K.Model specification & parameter estimation [Event Rlated Design]
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• Data & Designの設定

16. ‘Basis Functions’をクリック

17. ‘Canonical HRF’を選択

18. Batch Editorにある▶ボタンが緑色にな
り、スクリプトが実行可能になる。

19. [File] -> [Save Batch]で処理の内容を、例
えば‘Design.mat‘という名前を付けて保存
すれば、同じ条件の実験データについて
も[Specify 1st-level]->[File]->[Load Batch]で
利用できる

20. 緑色の▶ボタンをクリック、Design 
Matrix が計算され、‘SPM.mat‘として自動
保存される

21. Design Matirxが表示される

K.Model specification & parameter estimation [Event Rlated Design]
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• Estimation

1. ‘Estimate’をクリック

2. Batch Editorが表示される

3. ‘Select SPM.mat’をクリック

4. ‘Select Files’をクリック

5. ダイアログが現れるので、‘Data & 
Design’で作成された‘SPM.mat’を選択

6. ‘Done’をクリック

7. 矢印ボタンをクリックして実行

K.Model specification & parameter estimation [Event Rlated Design]
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• Results

1. ‘Results’をクリック

2. ファイル選択のダイアログが現れる

3. ‘Data & Design’で作成された‘SPM.mat’を選
択

4. ‘Done’をクリック

5. ‘SPM contrast manager’が現れる

K.Model specification & parameter estimation [Event Rlated Design]
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• Results

6. ‘t-contrast’をクリック

7. ‘Define new contrast...‘ボタンをクリック

8. name欄に‘HM’と入力

9. contrast欄に‘1 0’と入力

10. ‘OK‘ボタンをクリック

11. contrasts欄に出来上がったコントラスト
が表示される

12. 同様に‘VM‘コントラストについてもつく
る（name:’VM’, contrast:’0 1’）

K.Model specification & parameter estimation [Event Rlated Design]
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• Results

13. ‘001{T}:HM’を選択

14. ‘Done‘ボタンをクリック

15. ‘apply masking‘では‘none’をクリック

16. ‘title for comparison’に‘HM’と入力

17. ‘p value adjustment to control’では‘none’を
クリック

18. ‘threshold {T or p value}’にp値‘0.001’（デ
フォルト）を入力

19. ‘extent threshold {voxels}’に’0’（デフォル
ト）と入力

K.Model specification & parameter estimation [Event Rlated Design]
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• Results

20. Graphic windowにactivation mapが表示さ
れる.ただしCoregistrationしていないので
位置関係に意味は無い

21. ‘whole brain‘ボタンをクリックする

22. Graphic windowに全体のactivated clusters
が表示される. ただしCoregistrationしてい
ないので位置関係に意味は無い

K.Model specification & parameter estimation [Event Rlated Design]
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• Results

23. プルダウンメニュー‘overlays...’より

24. ‘sections’を選択

25. ダイアログにてEPIと同一スライスで撮像
した解剖画像‘anat_plan2.img’を選
択、‘Done‘ボタンをクリック

26. 解剖画像の上にactivationが重ねて表示さ
れる

K.Model specification & parameter estimation [Event Rlated Design]
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A～Eの手順で Normaliseがうまくいかない
例：

→定石：Segmentationの結果でやり直す。

L.Normaliseがうまくいかない場合：Segmentation
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1. ボタン‘Segment’をクリック

2. Batch Editorが出現

3. ‘Data’をクリック

4. ‘Select Files’をクリック

5. 高解像度解剖画像‘mazuda.3d.origX.img’を
選択

6. ‘Done’をクリック

7. ‘Custom’->‘Gaussian per class’を選択

8. ‘Edit Value’をクリック

9. デフォルトの’2 2 2 4’を’1 1 1 4’に変更

10. ‘OK’をクリック

L.Normaliseがうまくいかない場合：Segmentation
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11. 緑色になった▶ボタンをクリック

12. Segmentationが終了すると各種ファイル
が生成される

13. ‘Normalise (Write)’を選択

14. Batch Editorが開く。‘Data’をクリック

15. ‘New: Subject’を1回クリック

16. ‘Data’->‘Subject’->‘Parameter File’を選択

17. ‘Select Files’をクリック

18. 12でできたファイルのうち、‘matzuda.
3d.origX_seg_sn.mat’を選択

19. ‘Done’をクリック

L.Normaliseがうまくいかない場合：Segmentation
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20. ‘Images to Write’を選択

21. ‘Select Files’をクリック

22. 12でできたファイルのうち、‘matzuda.
3d.origX.img’を選択

23. ‘Done’をクリック

24. ‘Writing Options’->‘Voxel sizes’を選択

25. ‘Edit Value’を選択

26. 高解像度解剖画像の解像度を記す。ここ
では’1 1 1’。

27. 準備が整ったので、緑色になった▶ボタ
ンをクリック

L.Normaliseがうまくいかない場合：Segmentation
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28. Normaliseの結果は ‘matzuda.
3d.origX.img’の頭に’w’の付いた ‘wmatzuda.
3d.origX.img‘として保存される

29. 結果‘wmatzuda.3d.origX.img‘と標準
脳’T1.nii’の位置合わせを確認するた
め、‘Check Reg’をクリック

30. ファイル選択のダイアログで‘wmatzuda.
3d.origX.img‘と’T1.nii’とを続けて選択

31. Graphicsウィンドウに二つの画像が表示
される。いろいろな箇所をクリックして
位置合わせの精度を確認する。

L.Normaliseがうまくいかない場合：Segmentation
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1. ボタン‘Batch’をクリック

2. Batch Editorが出現

3. ‘SPM’タブをクリック。プルダウンメ
ニュー‘Spatial’->‘Realign’->‘Realigh: Estimate 
& Reslice’を選択

4. Batch Editorに ‘Realigh: Estimate & Reslice’が
追加される

5. 同様に必要な処理を順番に追加する。： 

‘Temporal’->‘Slice Timing’,                    
‘Coregister: Estimate’,                          
‘Normalise: Estimate & Write’,               
‘Smooth’

M.バッチ処理
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被験者に依存しないパラメタから設定する

6. ‘Slice Timing’で‘Data’を選択し‘New: 

Session’をクリックして追加。‘Session’を
選択した上で、‘Dependency’をクリック

7. ‘Session’選択ウィンドウが現れるので、
そこで”‘Realign: Estimate & Reslice: 

Resliced Images (Sess 1)’を選択し
て’OK‘ボタンをクリック

8. その他のパラメタを‘C.Slice Timing 
Correction‘にならって記入

M.バッチ処理
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9. ‘Coregister: Estimate’で‘Reference 
Image’に解剖画像‘anat_plan1X.img’を選
択

10. ‘Source Image’選択->‘Dependency‘クリッ
ク

11. ‘Source Image’選択ウィンドウが現れる
ので、‘Realign: Estimate & Reslice: Mean 
Image’を選択して’OK‘ボタン

12. ‘Other Images’選択->‘Dependency‘クリッ
ク

13. ‘Other Images’選択 ダイアログが現れる
ので、‘Slice Timing: Slice Timing Corr. 

Images (Sess 1)’を選択して’OK‘ボタン

M.バッチ処理
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14. ‘Normalise: Estimate & Write’で 
で‘Data’を選択し‘New: Subject’をクリッ
クして追加。‘Subject’->‘Source Image’を
選択した上で、‘Dependency’をクリック

15. ‘Source Image’選択ダイアログが現れる
ので、 ‘Slice Timing: Slice Timing Corr. 
Images (Sess 1)’を選択して’OK‘ボタン

16. ‘Subject’-> ‘Images to Write’を選択した上
で、‘Dependency’をクリック

17. ‘Images to Write’選択ダイアログが現れ
るので、 ‘Slice Timing: Slice Timing Corr. 
Images (Sess 1)’を選択して’OK‘ボタン

18. ‘Template Image‘として’/Application/spm8/
templates/EPI.nii’を選択

M.バッチ処理

10

14

15

16

17

18

2014年4月4日金曜日



19. ‘Smooth’で‘Images to Smooth’を選択
し‘Dependency’をクリック

20. ‘Images to Smooth’選択ダイアログが現
れるので、 ‘Normalise: Estimage & Write: 
Normalised Images (Subj 1)’を選択し
て’OK‘ボタン

21. これで一通りのパラメタは設定できた
ので、バッチデータを保存する

22. 最後に‘Realigh: Estimage & Reslice’に戻
り、‘Data’->‘Session’->‘Select Files’で対象
となる実験データ(exp1-****,img)をを選
択

23. これで準備ができたので、緑色に点灯
している実行ボタン「▶」をクリック
してバッチ処理を実行する

M.バッチ処理
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1. “/Applications/spm8/spm_defaults.m”を開く

2. ‘defaults.stats.topoFDR  = 1;’を 
‘defaults.stats.topoFDR  = 0;’に修正

3. MatLab再起動&SPM起動

4. Results:‘p value adjustment to control’の
際、‘FDR‘ボタンが追加されている事が確
認できる

【付録】FDR検定機能追加（activation）
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